Anfälligkeitssuche        Suche in 172616 CVE Beschreibungen
und 81291 Test Beschreibungen,
Zugriff auf 10,000+ Quellverweise.
Tests   CVE   Alle  

--------------------------------------------------------------------------------
Fedora Update Notification
FEDORA-2010-8575
2010-05-15 19:19:17
--------------------------------------------------------------------------------

Name        : gnustep-base
Product     : Fedora 12
Version     : 1.18.0
Release     : 9.fc12
URL         : http://www.gnustep.org/
Summary     : GNUstep Base library package
Description :
The GNUstep Base Library is a powerful fast library of general-purpose,
non-graphical Objective C classes, inspired by the superb OpenStep API but
implementing Apple and GNU additions to the API as well.  It includes for
example classes for unicode strings, arrays, dictionaries, sets, byte
streams, typed coders, invocations, notifications, notification dispatchers,
scanners, tasks, files, networking, threading, remote object messaging
support (distributed objects), event loops, loadable bundles, attributed
unicode strings, xml, mime, user defaults. This package includes development
headers too.

--------------------------------------------------------------------------------
Update Information:

Fix CVE-2010-1457 and CVE-2010-1602
--------------------------------------------------------------------------------
ChangeLog:

* Fri May 14 2010 Jochen Schmitt <sJOchen herr-schmitt de> - 1.18.0-9
- Fallback to 1.18. Backport security patches for #591602
* Thu May 13 2010 Jochen Schmitt <Jochen herr-schmitt de> 1.20.0-1
- New upatream release which fix CVE-2010-1457 and CVE-2010-1620 (#591602)
* Mon Nov 30 2009 Jochen Schmitt <Jochen herr-schmitt de> 1.18.0-8
- Remove strace command
* Thu Nov 26 2009 Jochen Schmitt <Jochen herr-schmitt de> 1.18.0-7
- Using temp. modified GNUstep.conf to access to DTDs (#539092)
* Thu Nov  5 2009 Jochen Schmitt <Jochen herr-schmitt de> 1.18.0-6
- Add a conflict agains libFoundation
--------------------------------------------------------------------------------
References:

  [ 1 ] Bug #591601 - CVE-2010-1457 CVE-2010-1620 gnustep-base: multiple vulnerabilities in gdomap
        https://bugzilla.redhat.com/show_bug.cgi?id=591601
--------------------------------------------------------------------------------

This update can be installed with the "yum" update program.  Use 
su -c 'yum update gnustep-base' at the command line.
For more information, refer to "Managing Software with yum",
available at http://docs.fedoraproject.org/yum/.

All packages are signed with the Fedora Project GPG key.  More details on the
GPG keys used by the Fedora Project can be found at
https://fedoraproject.org/keys
--------------------------------------------------------------------------------
_______________________________________________
package-announce mailing list
package-announce@lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/package-announce




© 1998-2020 E-Soft Inc. Alle Rechte vorbehalten.