Anfälligkeitssuche        Suche in 172616 CVE Beschreibungen
und 81291 Test Beschreibungen,
Zugriff auf 10,000+ Quellverweise.
Tests   CVE   Alle  

Test Kennung:1.3.6.1.4.1.25623.1.0.851777
Kategorie:SuSE Local Security Checks
Titel:openSUSE: Security Advisory for ocaml (openSUSE-SU-2018:1561-1)
Zusammenfassung:The remote host is missing an update for the 'ocaml'; package(s) announced via the referenced advisory.
Beschreibung:Summary:
The remote host is missing an update for the 'ocaml'
package(s) announced via the referenced advisory.

Vulnerability Insight:
This update for ocaml fixes the following issues:

- CVE-2018-9838: The caml_ba_deserialize function in byterun/bigarray.c in
the standard library had an integer overflow which, in situations where
marshalled data is accepted from an untrusted source, allows remote
attackers to cause a denial of service (memory corruption) or possibly
execute arbitrary code via a crafted object. [bsc#1088591]

This update was imported from the SUSE:SLE-12-SP2:Update update project.

Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or 'zypper patch'.

Alternatively you can run the command listed for your product:

- openSUSE Leap 42.3:

zypper in -t patch openSUSE-2018-559=1

Affected Software/OS:
ocaml on openSUSE Leap 42.3

Solution:
Please install the updated package(s).

CVSS Score:
7.5

CVSS Vector:
AV:N/AC:L/Au:N/C:P/I:P/A:P

Querverweis: Common Vulnerability Exposure (CVE) ID: CVE-2018-9838
https://caml.inria.fr/mantis/view.php?id=7765
CopyrightCopyright (C) 2018 Greenbone Networks GmbH

Dies ist nur einer von 81291 Anfälligkeitstests in unserem Testpaket. Finden Sie mehr über unsere vollständigen Sicherheitsüberprüfungen heraus.

Um einen gratis Test für diese Anfälligkeit auf Ihrem System durchlaufen zu lassen, registrieren Sie sich bitte unten.




© 1998-2020 E-Soft Inc. Alle Rechte vorbehalten.